Информатика, вопрос задал gordeevgrisha69 , 1 год назад

Написать программу на с++
Скорость передачи данных по локальной сети запрашивается у пользователя и измеряется в битах в секунду. Ученик качал игру * минут (время спрашивается у пользователя). Рассчитайте и выведите на экран размер (в Гбайт), который скачал ученик и сколько денег придется заплатить ему за трафик, если первый Гбайт не оплачивается, а все то, что сверху – по * рублям за Гбайт (спрашивается у пользователя).​

Ответы на вопрос

Ответил fostergleb93
1

Ответ:

#include <iostream>

using namespace std;

int main() {

int speed;

int time;

int price;

int size;

int cost;

cout << "Enter the speed (in bits per second): ";

cin >> speed;

cout << "Enter the time (in minutes): ";

cin >> time;

cout << "Enter the price (in rubles per gb): ";

cin >> price;

size = ((speed * time) / 8) / 1024 / 1024;

cost = (size - 1) * price;

cout << "Size downloaded: " << size << " GB" << endl;

cout << "Total cost: " << cost << " rubles" << endl;

return 0;

}

Объяснение:

Новые вопросы