Информатика, вопрос задал fallenrog , 10 лет назад

Написать программу на С++ помогите пожалуйста.
Найти сумму элементов последовательности b1,b2........ , b15 ,  расположенных правее последнего отрицательного элемента и номер этого элемента.

Ответы на вопрос

Ответил yuliagal
0
#include <iostream>

using namespace std;

int main()
{
    int a[15];
    int i = 0;
    int sum = 0;
    for (; i < 15; i++)
        cin >> a[i];
    for (i = 14; (i != 0) && (a[i]>0); i--) 
        sum += a[i];
   
    cout << "i = " << i+1 << endl;
    cout << "summa = " << sum << endl;
    return 0;
}
Ответил yuliagal
0
вам приглашение на ввод добавить? )
Ответил yuliagal
0
изменила немного код, чтобы был поменьше и покрасивше
Новые вопросы