Информатика, вопрос задал UAGamesTactics , 8 лет назад

Написать программу на С++. Написать подпрограмму, которая находит максимальную цифру заданного числа и выводит её на экран.

Ответы на вопрос

Ответил srzontmp
0
#include <iostream>
using namespace std; 

void mxd(int n) {
    int k,mx=0;
    do {
       k=n%10; n/=10;
       if (k>mx) mx=k;
    }
    while (n>0);   
    cout<<mx<<endl; 
}    

int main() {   
    int n;
    cout<<"number: ";  cin>>n;
    mxd(n);
    system("pause");
    return 0;
}


Новые вопросы