Написать программу на С++. Написать подпрограмму, которая принимает один аргумент и выводит на экран факториал переданного ей числа.
Ответы на вопрос
Ответил srzontmp
0
#include <iostream>
using namespace std;
void fac(int n) {
int s=1;
for (int i=1; i<=n; i++) s*=i;
cout<<s<<endl;
}
int main() {
int n;
cout<<"number: "; cin>>n;
fac(n);
system("pause");
return 0;
}
using namespace std;
void fac(int n) {
int s=1;
for (int i=1; i<=n; i++) s*=i;
cout<<s<<endl;
}
int main() {
int n;
cout<<"number: "; cin>>n;
fac(n);
system("pause");
return 0;
}
Новые вопросы