Написать программу на с++, которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей.
Приложения:

Ответы на вопрос
Ответил PatifonKakao
0
#include <conio.h>
#include <iostream>
#include <string>
using namespace std;
int main(int argc, char *argv[])
{
setlocale(LC_ALL,"Russian");
string str;
getline(cin,str);
int i=0,digit=0;
while (str[i] != ' '){
if (str[i] >= '0' && str[i] <= '9')
digit++;
i++;
}
char ch='-';
if (digit>(i-digit))
ch='+';
for(int j=0; j<i; j++){
str[j]=ch;
cout<<str[j];
} _getch();
return 0;
}
#include <iostream>
#include <string>
using namespace std;
int main(int argc, char *argv[])
{
setlocale(LC_ALL,"Russian");
string str;
getline(cin,str);
int i=0,digit=0;
while (str[i] != ' '){
if (str[i] >= '0' && str[i] <= '9')
digit++;
i++;
}
char ch='-';
if (digit>(i-digit))
ch='+';
for(int j=0; j<i; j++){
str[j]=ch;
cout<<str[j];
} _getch();
return 0;
}
Ответил Siaroza
0
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Биология,
9 лет назад
Алгебра,
9 лет назад
Математика,
10 лет назад