Написать программу на "С#" для решения следующей задачи:
найти наибольший элемент числовой последовательности, вывести его порядковый номер и значение.
Ответы на вопрос
using System;
using System.Collections.Generic;
using System.Linq;
namespace ConsoleApp1
{
class Program
{
static void Main(string[] args)
{
// Ввод данных
Console.WriteLine("Введите числовую последовательность разделённую пробелами: ");
List<string> str_nums = Console.ReadLine().Split(' ').ToList();
// Обработка
List<int> nums = str_nums.ConvertAll(int.Parse);
int max = nums[0];
int max_i = 0;
for (int i = 0; i < nums.Count; i++)
{
max_i = (nums[i] > max) ? i : max_i;
max = (nums[i] > max) ? nums[i] : max;
}
// Вывод данных
Console.WriteLine("Максимальное число {0}", max);
Console.WriteLine("Порядковый номер {0}", max_i + 1);
}
}
}