Написать программу на С++..
Даны координаты двух полей шахматной доски (координаты клетки - это 2 числа от 1 до 8: номер столбца и номер строки)
Одно ли цвета эти клетки на шахматной доске? Вывести в выходной файл сообщение YES, если они одного цвета, и NO иначе
Пример ввода:
1 1 2 2
Пример вывода:
YES
Пример ввода:
1 1 1 4
Пример вывода:
NO
Ответы на вопрос
Ответил KarinLir
0
Ответ:
#include <iostream>
using namespace std;
int main(){
int x1, y1, x2, y2, d;
cout<<"Введите координаты 1 клетки" << endl;
cin>>x1;
cin>>y1;
cout<<"Введите координаты 2 клетки" <<endl;
cin>>x2;
cin>>y2;
d = x1 + y1 + x2 + y2;
if (d % 2 == 0) {
cout<<"YES";
}
else cout<<"NO";
return 0;
}
Объяснение:
Новые вопросы
Українська мова,
2 года назад
Українська мова,
2 года назад
Русский язык,
2 года назад
Математика,
8 лет назад