Информатика, вопрос задал Tartimilka1 , 1 год назад

написать программу на python

В клетке сидят фазаны и кролики. Известно, что у них 35 голов и 94 ноги. Определить количество фазанов и кроликов.

Входные данные: Количество голов G и количество ног N. (1<=G,N<=1000000) /

Выходные данные: Вывести в одной строе число фазанов и число кроликов или сообщение no, если задача не имеет решение.

Формат ввода
Пример 1

35 94

Пример 2

45 84

Формат вывода
Пример 1

23 12

Пример 2

no

Приложения:

Ответы на вопрос

Ответил XDXDXDXDXDXDXO
0

Код:

def find_animals_heads_legs(G, N):

   # Проверка на неотрицательность и целочисленность решения

   if (N - 2 * G) % 2 == 0 and (N - 2 * G) >= 0:

       R = (N - 2 * G) // 2

       F = G - R

       return F, R

   else:

       return None

# Ввод данных

G, N = map(int, input().split())

# Вызов функции и вывод результатов

result = find_animals_heads_legs(G, N)

if result:

   print(result[0], result[1])

else:

   print("no")

Результат вывода кода:
Ввод:

35 94

Вывод:

23 12

Ввод:

45 84

Вывод:

no

Новые вопросы