Информатика, вопрос задал Tartimilka1 , 1 год назад

написать программу на python
В кануне каникул для учащихся гимназии №5 закуплены билеты в клуб "Фабрика" на некоторую сумму денег. Но стоимость билетов различна: есть билеты, по которым можно пройти на дискотеку и во время танцев пить сколько угодно Пепси, а есть билеты, по которым можно делать тоже, но еще прилагается пицца.

Известно количество билетов, сумма денег, стоимость первых и вторых билетов. Определите количество первых и вторых билетов.

Входные данные: Количество билетов, сумма денег, стоимость билетов первого типа, стоимость билетов второго типа.

Выходные данные: Количество билетов первого типа, количество билетов второго типа, или сообщение no , если задача не имеет решение.

Формат ввода
Пример 1

100 3400 30 40

Пример 2

80 1400 50 90

Формат вывода
Пример 1

60 40

Пример 2

no

Приложения:

Ответы на вопрос

Ответил XDXDXDXDXDXDXO
0

Код:
def calculate_tickets_count(total_tickets, total_money, ticket_type_1, ticket_type_2):

   y = (ticket_type_1 * total_tickets - total_money) / (ticket_type_2 - ticket_type_1)

   x = total_tickets - y

   if x >= 0 and y >= 0 and y.is_integer():

       return int(x), int(y)

   else:

       return None

# Ввод данных

total_tickets, total_money, ticket_type_1, ticket_type_2 = map(int, input().split())

# Вызов функции и вывод результатов

result = calculate_tickets_count(total_tickets, total_money, ticket_type_1, ticket_type_2)

if result is not None:

   print(result[0], result[1])

else:

   print("no")

Вывод/Ввод:

Ввод:

100 3400 30 40

Вывод:

60 40

Ввод:

80 1400 50 90

Вывод:

no


Tartimilka1: у меня дзен не зачел этот ответ(
XDXDXDXDXDXDXO: ну хз хз, у меня всё верно написано
Новые вопросы