Информатика, вопрос задал hasbula228 , 1 год назад

Написать программу на python которая
принимает 2 числа и делит одно на
другое,там сделать много исключений и
обработок.


Мартын05: какие исключения и обработки? типа защита от дурака?

Ответы на вопрос

Ответил geniuskost
1

Відповідь:

Пояснення:

while True:

   try:

       num1 = float(input("Введите первое число: "))

       num2 = float(input("Введите второе число: "))

       result = num1 / num2

   except ValueError:

       print("Ошибка: введено некорректное значение!")

   except ZeroDivisionError:

       print("Ошибка: нельзя делить на ноль!")

   else:

       print(f"{num1} / {num2} = {result}")

       break

Новые вопросы