Информатика, вопрос задал dmpurgin , 7 лет назад

Написать программу на Python которая напечатает все возможные комбинации слов (от A до Z) в консоль.
Именно все возможные, вот прямо всё что можно написать используя только 4 символа английского алфавита

Ответы на вопрос

Ответил лекция
1

a = 'A , B , C , D , E , F , G , H , I , J , K , L , M , N , O , P , Q , R , S , T , U , V , W , X , Y , Z'

a = a.replace(',', '')

a = a.replace(' ', '')

for k in a:

   for l in a:

       for m in a:

           for n in a:

               print(k + l + m + n)

насчет повторов не уверен, если будут, то:

l = []

a = 'A , B , C , D , E , F , G , H , I , J , K , L , M , N , O , P , Q , R , S , T , U , V , W , X , Y , Z'

a = a.replace(',', '')

a = a.replace(' ', '')

for k in a:

   for l in a:

       for m in a:

           for n in a:

               l.append(k + l + m + n)

l = set(l)

for i in l:

   print(i)


лекция: правда у меня выдает [omitting some output]
лекция: и печатает не все
лекция: в консоли на все нет места
restIess: Во втором косяк небольшой, там у тебя переменная "l" в цикле + список имеет имя "l", из-за этого ошибка будет
лекция: спасибо, отредачить уже не могу
Новые вопросы