Информатика, вопрос задал kirillanjaro , 6 лет назад

Написать программу на питоне!
В данном упражнении вы должны написать программу для подсчета среднего значения всех введенных пользователем чисел. Индикатором окончания ввода будет служить ноль. При этом программа должна выдавать соответствующее сообщение об ошибке, если первым же введенным пользователем значением будет ноль.
Примечания
А. Поскольку ноль является индикатором окончания ввода, его не нужно учитывать при расчете среднего.
Б. Решить поставленную задачу при условии, что исходные числа будут задаваться генератором случайных чисел

Ответы на вопрос

Ответил Rediska873
1

num = float(input())

if(num == 0):

   print("Error")

   exit(0)

sum = 0

amount = 0

while num != 0:

   sum += num

   amount += 1

   num = float(input())

print("Average:", sum / amount)

Новые вопросы