Информатика, вопрос задал ninom21 , 7 лет назад

Написать программу на питоне которая выводит сколько в корзине (гриб,гриба,грибов)

Приложения:

maxnn939: что?

Ответы на вопрос

Ответил TEAHUS
1

Ответ:

Решение 1:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

plural_generative = [5, 6, 7, 8, 9, 0]  # список окончаний род.падеж множ-го: грибов

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнюю цифру из числа"""

   if (number % 10) == nominative:  

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   elif (number % 10) in plural_generative:

       print(f"{number} грибов")

Решение 2:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнию цифру из числа"""

   if (number % 10) == nominative:

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   else:

       print(f"{number} грибов")

Объяснение:

В комментариях.


TEAHUS: Надеюсь на адекватное оценивание и лучший ответ)
ninom21: вы лучший просто
Новые вопросы