Информатика, вопрос задал hasbula228 , 1 год назад

Написать программу на питоне которая будет считывать есть ли в input символы верхнего английского регистра.

Ответы на вопрос

Ответил ilyav1nokurov
3

Вот пример программы на Python, которая проверяет, есть ли вводимые символы верхнего английского регистра:

input_str = input("Введите строку: ")

flag_upper = False

for char in input_str:

   if char.isupper():

       flag_upper = True

       break

if flag_upper:

   print("В строке есть символы верхнего английского регистра")

else:

   print("В строке нет символов верхнего английского регистра")

Объяснение:

Программа считывает строку с помощью функции input(), а затем проходит по каждому символу в строке с помощью цикла for. Если хотя бы один символ имеет верхний регистр, то устанавливается флаг flag_upper в значение True. После цикла программа проверяет значение флага и выводит соответствующее сообщение.


hasbula228: Огромное спасибо
Ответил Аноним
2

Ниже наведен простой скрипт на Python, который проверяет текст на верхний регистр.

string = input('Введите текст для проверки: ')

# Проверка

if any(char.isupper() for char in string if char.isalpha()):

   print('В тексте есть верхний регистр!')

else:

   print('Текст прошёл проверку!\nВ тексте ничего не обнаружено')

Новые вопросы