Информатика, вопрос задал ПОЧЕМУЧКА3214 , 6 лет назад

Написать программу на питоне ДАЮ 100 баллов

Приложения:

Леганда555: а есть тестирующая система? чтобы своё решение проверить
ПОЧЕМУЧКА3214: Да
Леганда555: пришли ссылку пожалуйста, чтобы тебе ложное решение не прислать
ПОЧЕМУЧКА3214: К системе только у меня доступ,так что не могу
ПОЧЕМУЧКА3214: Я напишу если неверныый

Ответы на вопрос

Ответил Леганда555
2

a, b, c = int(input()), int(input()), int(input())

x = a + c - b

y = b + c - a

z = a + b - c

if all(i % 2 == 0 for i in [x, y, z]):

   print(x // 2, 0, x // 2)

   print(0, y // 2, y // 2)

   print(z // 2, z // 2, 0)

else:

   print('Impossible')

Новые вопросы