написать программу на паскале, запрашивающую возраст пользователя, если ему не менее 18 лет сообщите ему что он имеет право голосовать, в противном случае вычислите через сколько лет ему предоставят это право.
Ответы на вопрос
Ответил forusser
0
var
c.d:byte;
begin
writeln ('Введите ваш возраст');
readln (c);
D:=18-c
if c>17 then writeln ('Вы достаточно взрослы, чтобы голосовать');
if c<18 then writeln ('Вы слишком малы, чтобы голосовать, вы сможете голосовать через',d,'лет');
readln;
end.
c.d:byte;
begin
writeln ('Введите ваш возраст');
readln (c);
D:=18-c
if c>17 then writeln ('Вы достаточно взрослы, чтобы голосовать');
if c<18 then writeln ('Вы слишком малы, чтобы голосовать, вы сможете голосовать через',d,'лет');
readln;
end.
Ответил forusser
0
var
c.d:byte;
begin
writeln ('Введите ваш возраст');
readln (c);
D:=18-c;
if c>17 then writeln ('Вы достаточно взрослы, чтобы голосовать');
if c<18 then writeln ('Вы слишком малы, чтобы голосовать, вы сможете голосовать через',d,'лет');
readln;
end.
c.d:byte;
begin
writeln ('Введите ваш возраст');
readln (c);
D:=18-c;
if c>17 then writeln ('Вы достаточно взрослы, чтобы голосовать');
if c<18 then writeln ('Вы слишком малы, чтобы голосовать, вы сможете голосовать через',d,'лет');
readln;
end.
Ответил helpplspls
0
только вместо :byte; надо :integer;
Ответил forusser
0
ну разницы нет, только на 2 байта больше интегер весит
Новые вопросы
Русский язык,
2 года назад
Геометрия,
2 года назад
Литература,
9 лет назад
География,
9 лет назад
Геометрия,
10 лет назад