написать программу на паскале
Треугольник задан координатами (x1, y1), (x2, y2), (x3, y3) своих вершин. Вычислить радиус окружности, вписанной в треугольник
Ответы на вопрос
Ответил BlackW1nd
0
Var x1,y1,x2,y2,x3,y3,a,b,c,p,r:real;
Begin
write('A='); readln(x1,y1);
write('B='); readln(x2,y2);
write('C='); readln(x3,y3);
a:=sqrt(sqr(x1-x2)+sqr(y1-y2));
b:=sqrt(sqr(x2-x3)+sqr(y2-y3));
c:=sqrt(sqr(x1-x3)+sqr(y1-y3));
p:=(a+b+c)/2;
r:=sqrt(((p-a)*(p-b)*(p-c))/p);
writeln('r=',r:0:2);
End.
Begin
write('A='); readln(x1,y1);
write('B='); readln(x2,y2);
write('C='); readln(x3,y3);
a:=sqrt(sqr(x1-x2)+sqr(y1-y2));
b:=sqrt(sqr(x2-x3)+sqr(y2-y3));
c:=sqrt(sqr(x1-x3)+sqr(y1-y3));
p:=(a+b+c)/2;
r:=sqrt(((p-a)*(p-b)*(p-c))/p);
writeln('r=',r:0:2);
End.
Ответил vitokb
0
спасибо чувак, люблю тебя
Новые вопросы