Информатика, вопрос задал 1925Natasha1925 , 10 лет назад

написать программу на паскале:определить количество строк матрицы, в которых хотя бы один элемент равен t

Ответы на вопрос

Ответил Sky09
0

uses crt;
var
  a:array [1..100,1..100] of real;
  t:real; i,j,k:integer;
begin
  randomize;
  write('Введите количество строк матрицы: '); read(i);
  write('Введите количество столбцов матрицы: '); read(j);
  write('Введите число t: '); read(t);
  clrscr;
  for i:=1 to i do
  begin
    for j:=1 to j do
    begin
      a[i,j]:=random(100)-50;
      write(a[i,j],' ');
    end;
    writeln;
  end;
  k:=0;
  for i:= 1 to i do
  begin
    for j:= 1 to j do
    begin
      if a[i,j]=t then
      begin
        k:=k+1;
        j:=1;
        i:=i+1;
      end;
    end;
  end;
 writeln('Количество строк: ',k);
end.

Ответил Alphaeus
0

Program Natasha1925_2;
uses crt;
const n=50;
var
  a:array[1..n,1..n] of integer;
  t:integer;
  i,j,kwo:integer;
  yes:boolean;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  randomize;
  {создание массива}
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          a[i,j]:=random(101)-50;
          write(a[i,j]:7:2);
        end;
      writeln();
    end;
  write('Введите число t: '); read(t);
  {поиск строк}
  kwo:=0;
  for i:=1 to n do
    begin
      yes:=FALSE;
      for j:=1 to n do
        if a[i,j]=t then
          yes:=TRUE;
      if yes then kwo:=kwo+1;
    end;
 writeln('Количество строк: ',kwo);
end.

Новые вопросы