Информатика, вопрос задал lime1study , 2 года назад

Написать программу на Паскале, которая выводит последнюю цифру числа

Ответы на вопрос

Ответил AlvaroMarvin
0

Ответ:

var a,b:integer;

Begin

readln(a);

b:=a mod 10;

writeln(b);

End.

Объяснение:

Мы вводим некое число а, например 100 mod означает деление с остатком, тоесть мы делим число 100 на 10 и находим остаток от деления, остатком будет 0.


lime1study: какая будет разница если написать a mod 2?
AlvaroMarvin: на данном примере разницы никакой, но если взять например число 102 то если сделаешь mod 2 в ответе выдаст 0, а правильный ответ 2
Новые вопросы