Информатика, вопрос задал Aforikss , 8 лет назад

Написать программу на паскале
Известно расписание поездов проходящих через станцию:
-Номер поезда
-назначание(например, Москва-Омск)
-часы и минуты прибытия на станцию
-часы и минуты отправления со станции.
Поезда приходят каждый день. По данному времени определить какие поезда(номера и назначения) стоят в этот момент на станции.

Ответы на вопрос

Ответил karicha2000
0
var h,m,t:integer;

begin
write('Введите время(ч,м): '); read(h,m);
t:=h*60+m;

writeln('В данный момент на станции стоят следующие поезда: ');
if (t>=540) and (t<590) then writeln('Номер 1, Красноярск- Москва ');
if (t>=570) and (t<620) then writeln('Номер 2, Новгород - Москва ');
if (t>=610) and (t<670) then writeln('Номер 3, С.-Петербург - Калининград ');
if (t>=660) and (t<720) then writeln('Номер 4, Владивосток - Москва ');
if (t>=720) and (t<750) then writeln('Номер 5, Москва - Омск ');
if (t>=755) and (t<795) then writeln('Номер 6, Томск — Москва ');
if (t>=780) and (t<830) then writeln('Номер 7, Москва — Екатеринбург ');
if (t>=820) and (t<860) then writeln('Номер 8, Москва — Самара ');
if (t>=845) and (t<910) then writeln('Номер 9, С.-Петербург — Москва ');
if (t>=890) and (t<950) then writeln('Номер 10, Москва — Красноярск ');
if (t>=940) and (t<990) then writeln('Номер 11, Москва — Владивосток ');
if (t>=980) and (t<1025) then writeln('Номер 12, Омск-Москва ');
if (t>=1020) and (t<1085) then writeln('Номер 13, Москва — С.-Петербург ');
if (t>=1080) and (t<1140) then writeln('Номер 14, Екатеринбург — Москва ');
 end.
Приложения:
Новые вопросы