Информатика, вопрос задал winex2018 , 7 лет назад

Написать программу на Паскале, используя цикл. Суть программы: вводится число, а программа определяет, каких цифр больше: чётных или нечётных.

Ответы на вопрос

Ответил 13nisa13
0

var n,k1,k2:integer;

begin

write ('Введите число: ');

readln(n);

while n>0 do

begin

if n mod 10 mod 2 = 0 then k2:=k2+1

else k1:=k1+1;

n:=n div 10

end;

if k1>k2 then write ('Нечётных цифр в числе больше')

else write ('Чётных цифр в числе больше')

end.

Новые вопросы