Написать программу на паскале
Если данное число х меньше нуля, то Z присвоить значение большего из 2 чисел х и у, иначе Z присвойте значение полсуммы этих чисел.
Ответы на вопрос
Ответил PsyhoAssasin
4
Program Z;
Uses Crt;
var x,y,z:real;
begin
clrscr;
write('Введите х: ');
readln(x);
write('Введите y: ');
readln(y);
if (x<0) and (x>y) then z:=x;
if (x<0) and (x<y) then z:=y;
if (x>=0) then z:=(x+y)/2;
writeln('z=',z);
readkey;
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Физика,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад