Информатика, вопрос задал serzhsmirnov93 , 8 лет назад

Написать программу на Паскале для вычисления стоимости покупки, состоящей из нескольких тетрадей и такого же количества обложек к ним. Результат должен выводиться в денежном формате, например, 145руб. 30коп.

Ответы на вопрос

Ответил Krusty76
0
Program n_5;

var
   a, b: real;
   c: integer;

begin
  write('Введите стоимость тетради - '); readln (a);
  write('Введите стоимость обложки - '); readln (b);
  write('Введите кол-во тетрадей - '); readln (c);
  if (a <= 0) or (b <= 0) or (c <= 0) then exit;
  writeln;
  write('ИТОГО: ', trunc(c * (a + b)), ' руб. ', round(((c * (a + b)) - (trunc(c * (a + b))))*100), ' коп.');
end.
Ответил Krusty76
0
В моём Паскале АВС.NET всё работает на ура. Спасибо за задачу, над разделением на рубли и копейки пришлось поломать голову)
Ответил serzhsmirnov93
0
Спасибо огромное! Все верно.
Новые вопросы