Информатика, вопрос задал zlatasifurova , 8 лет назад

Написать программу на паскале для определения числа членов ряда,вошедших в сумму.Исходные данные 0.62,точность вычисления 10^-4.s= frac{1}{6}sinx- frac{1}{24}sinx+...+  frac{ (-1)^{n} }{n( n^{2}-1) } sin(x)+...

Ответы на вопрос

Ответил petyaGavrikov
0
const eps=1e-4;
var n,z:integer; x,sx,an,s:real;
begin
x:=0.62;
sx:=sin(x);
n:=1; z:=-1; 
an:=1; s:=0;
while abs(an)>eps do
 begin
 z:=-z;
 n:=n+1;
 an:=z*sx/(n*(n*n-1));
 s:=s+an;
 end;
writeln('k = ',n-1,' s = ',s);
end.

Результат:
k = 17 s = 7.92376332816429E-002
Новые вопросы