Информатика, вопрос задал Nelly6587 , 7 лет назад

Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π×D, S = π×D2(в квадрате) /4

Ответы на вопрос

Ответил skorohodandryuha
0

const

 pi = 3.14;

var

 S, D, L: real;

begin

 write('Введите площадь круга: S = ');

 readln(S);

 D := 2 * sqrt(S / pi); { <-- Вычисляем диаметр круга }

 L := pi * D; { <-- Вычисляем длину окружности }

 writeln('Результат:');

 writeln(' D = ', D:0:2); { <-- Выводим диаметр на экран }

 writeln(' L = ', L:0:2); { <-- Выводим длину на экран }

 readln

end.

Новые вопросы