Написать программу на Pascal, попадает ли точка с заданными координатами в область?
Приложения:


Ответы на вопрос
Ответил nikolac
0
program task2;
var R, x, y : real;
begin
writeln('Введите значения R, x, y:');
read(R, x, y);
if (((x >= 0) and (y >= 0) and (x * x + y * y <= R * R)) or ((x < 0) and (y < 0) and (y >= -x - R))) then
writeln('Точка с координатами x: ', x, ', y: ', y, ' принадлежит заданной области.')
else
writeln('Точка с координатами x: ', x, ', y: ', y, ' не принадлежит заданной области.');
end.
var R, x, y : real;
begin
writeln('Введите значения R, x, y:');
read(R, x, y);
if (((x >= 0) and (y >= 0) and (x * x + y * y <= R * R)) or ((x < 0) and (y < 0) and (y >= -x - R))) then
writeln('Точка с координатами x: ', x, ', y: ', y, ' принадлежит заданной области.')
else
writeln('Точка с координатами x: ', x, ', y: ', y, ' не принадлежит заданной области.');
end.
Новые вопросы