Информатика, вопрос задал nikitaandrievskii200 , 1 год назад

Написать программу на Pascal.
Дан одномерный массив A(1000) натуральных чисел,не превосходящих 10000. Определить количество двухзначных четных чисел, не делящихся на 4 и найти их сумму.

Ответы на вопрос

Ответил petyaGavrikov
0

Ответ:

const n=1000;

var a:array[1..n] of integer;

i,k,s:integer;

begin

Randomize;

for i:=1 to n do

a[i]:=random(10000);

k:=0; s:=0;

for i:=1 to n do

if (a[i]>9)and(a[i]<100)and(a[i] mod 2=0)and(a[i] mod 4<>0) then

begin k:=k+1; s:=s+a[i]; end;

writeln('k = ',k,' s = ',s);

end.

Пример:

k = 3 s = 198

Новые вопросы