Информатика, вопрос задал nastyasergeevn1 , 2 года назад

Написать программу на Pacal
задачи:
1.Дано два ненулевых числа проверить истинность высказывания "числа имеют разные знаки".
2. Дано два целых числа проверить истинность высказывания " оба числа четные".

Ответы на вопрос

Ответил Klyk
1
1.
var a,b:integer;
begin
readln(a);
readln(b);
if ((a>0) and (b>0)) Or ((a<0) and (b<0)) 
writeln('У обоих чисел одинаковые знаки')
else
writeln('У чисел разные знаки') ;
end.
2.
var a,b:integer;
begin
readln(a);
readln(b);
if (a mod 2=0) And (b mod 2=0) then
writeln('Высказывание истинно')
else
writeln('Высказывание ложно') 
end.
Новые вопросы