Другие предметы, вопрос задал 1199991193 , 7 лет назад

Написать программу на C#ю
Даны действительные числа x, y, z. Вычислить: а) max (x + y + z, xyz);
б) min2 (x + y + z/2, xyz) +1.

Ответы на вопрос

Ответил panicanna
2

Ответ:

using System;

namespace ConsoleApp3

{

   class Program

   {

       static void Main(string[] args)

       {

           Console.WriteLine("Введите x");

          double x = Convert.ToInt32(Console.ReadLine());

           Console.WriteLine("Введите y");

           double y = Convert.ToInt32(Console.ReadLine());

           Console.WriteLine("Введите z");

           double z = Convert.ToInt32(Console.ReadLine());

        // a)

           double sum = x + y + z; // сумма

           double mlp = x * y * z; //произведение

           if (sum < mlp)

               Console.WriteLine(" max({0}; {1})={2}",sum,mlp, mlp);

           else

               Console.WriteLine(" max({0}; {1})={2}", sum, mlp, sum);

           // б)

           double min = x + y + z / 2;

           if (x * y * z < min)

               min = x * y * z;

           Console.WriteLine(" min={0}", min+1);

       }

   }

}

Объяснение:

если есть вопросы или что-то не так, пишите

а) подробнее получился, б) увидела проще и логичнее на паскале и просто переписала на с#


nazekka03: а как можно без массива?
nazekka03: б)
panicanna: здесь нет массива
Новые вопросы