Написать программу на C++
С клавиатуры вводится число n. Написать программу, находящую сумму и произведение его цифр, результат вывести на экран. Подсказка: в цикле пока число n больше 0: - с помощью целочисленной операции % извлекать последнюю цифру числа n, добавлять её к сумме и увеличивать произведение; - на каждом шаге избавляться от последнего разряда числа n путем деления нацело на 10.
Ответы на вопрос
Ответил vimmortal2
2
Программа:
C++:
#include <iostream>
using namespace std;
int main()
{
int n, summ = 0; // регистрируются переменные для чисел
cin >> n; // вводится число n
while (n > 0) { // пока n положительно
summ += n % 10; // к summ прибавляем последнюю цифру числа
n /= 10; // делим n на 10, тем самым убираем последнюю цифру
}
cout << summ; // выводим summ
}
Результат:
123
6
7731
18
9876
30
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
6 лет назад
Математика,
6 лет назад
Алгебра,
8 лет назад
Литература,
8 лет назад