Информатика, вопрос задал Simplleboy , 1 год назад

Написать программу на C++

Даны два угла треугольника (в градусах). Определить, существует ли
такой треугольник. Если да, то будет ли он прямоугольным.

Ответы на вопрос

Ответил fedrfedr
2

Ответ:

#include <iostream>

using namespace std;

int main()

{

 setlocale(LC_ALL, "russian");

 int a, b, c;

 cout << "Введите два угла треугольника в градусах: ";

 cin >> a >> b;

 c = 180 - b - a;

 if (a > 0 && b > 0 && c > 0) {

   cout << "\nТреугольник существует.";

   if (a == 90 || b == 90 || c == 90)

     cout << "\nЭто прямоугольный треугольник.";

 }

 else

   cout << "\nТреугольник не существует.";

}

Новые вопросы