Написать программу на алгоритмическом языке PASCAL с использованием любого оператора(номер 8)
Приложения:

Ответы на вопрос
Ответил Аноним
0
Увидел ответ для PascalABC.NET и не сдержался)))
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
var u:=ReadReal('u=');
var x:=-2.3;
Range(-23,12,2).Select(k->k/10)
.Tabulate(x->x<=-1?Power(Cos(Power(x,4)),3):x<0.5?u/2:x*x/(x*x*x+1))
.Foreach(t->Writeln(t[0]:4:1,t[1]:15:10))
end.
Результат
u= 3
-2.3 -0.8797052525
-2.1 0.5638810103
-1.9 0.7133050404
-1.7 -0.1090601034
-1.5 0.0403543461
-1.3 -0.8834179090
-1.1 0.0012077455
-0.9 1.5000000000
-0.7 1.5000000000
-0.5 1.5000000000
-0.3 1.5000000000
-0.1 1.5000000000
0.1 1.5000000000
0.3 1.5000000000
0.5 0.2222222222
0.7 0.3648548027
0.9 0.4684788895
1.1 0.5190905191
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
var u:=ReadReal('u=');
var x:=-2.3;
Range(-23,12,2).Select(k->k/10)
.Tabulate(x->x<=-1?Power(Cos(Power(x,4)),3):x<0.5?u/2:x*x/(x*x*x+1))
.Foreach(t->Writeln(t[0]:4:1,t[1]:15:10))
end.
Результат
u= 3
-2.3 -0.8797052525
-2.1 0.5638810103
-1.9 0.7133050404
-1.7 -0.1090601034
-1.5 0.0403543461
-1.3 -0.8834179090
-1.1 0.0012077455
-0.9 1.5000000000
-0.7 1.5000000000
-0.5 1.5000000000
-0.3 1.5000000000
-0.1 1.5000000000
0.1 1.5000000000
0.3 1.5000000000
0.5 0.2222222222
0.7 0.3648548027
0.9 0.4684788895
1.1 0.5190905191
Новые вопросы