Информатика, вопрос задал kotikmyaukalka , 2 года назад

Написать программу который принимает с клавиатуры два положительных, двузначное и четырёхзначное, и проверяет, сколько раз двузначное число фигурирует как внутреннее по отношению к четырёхзначному.

Пример:

Ввод 1: 2525

Ввод 2: 25

Результат: 2


zhoramalushevpegkpk: точно класс, а не функцию или процедуру?
kotikmyaukalka: Программу, функцию

Ответы на вопрос

Ответил zhoramalushevpegkpk
0

Ответ:

begin

 var a,b,c:integer;

 write('Введите числа a,b: '); readln(a,b);

         for var l:=1 to 3 do if (a.ToString[l]+a.ToString[l+1])=b.ToString then inc(c);

         writeln('Результат: ',(c>0)? c.ToString:'Число a не является внутренним для b');

end.

Примечание:

Если хотите сделать защиту от некорректного ввода, то программа будет выглядеть так:

begin

 var a,b,c:integer;

 write('Введите числа a,b: '); readln(a,b);

 

 if (a.ToString.Length<>4) or (a<0) then

   writeln ('Число а должно быть положительным четырехзначным')else

     begin

   if (b.ToString.Length<>2) or (b<10) then

     writeln ('Число b должно быть положительным двухзначным') else

       

       begin

         for var l:=1 to 3 do if (a.ToString[l]+a.ToString[l+1])=b.ToString then inc(c);

         writeln('Результат: ',(c>0)? c.ToString:'Число a не является внутренним для b');

       end;

   end;

end.

Новые вопросы