Информатика, вопрос задал Аноним , 2 года назад

написать программу которвя вычисляет сумму n первых чисел кратных 2

Ответы на вопрос

Ответил musicwave15
0

На будущее, уточняйте на каком языке программирования нужно написать. Так как не указано язык программирования, то я просто напишу алгоритм, а Вы уже сами постараетесь перевести на нужный язык.

int sum; - создаем переменную sum;

int n; - создаем переменную n;

int index = 0; - создаем переменную index, при помощи которой будем считать сколько раз введено число, которое кратное 2;

while(index != 2){ - создаем цикл, который будет спрашивать ввод числа n до тех пор, пока мы не напишем два числа которые будут кратные 2;

cin >> n; - вводим наше n;

if( (n % 2) == 0){ - пишем условия, в котором проверяем, если остаток от деления на 2, равен 0, то мы делаем некоторые вещи, а именно:

sum = sum + n; - в нашу суму добавляем число n;

index = index + 1; - "записываем" в index понятие, что мы нашли уже одно число.

}

cout << sum; - выводим нашу итоговую сумму.

}

Новые вопросы