Написать программу которая запрашивает текст и символ, считает сколько раз этот символ встречается в тексте. Написать на С++.
Решить самому,и подробное объяснение .
Ответы на вопрос
Ответил abob334
0
#include <iostream>
#include <string>
int main() {
std::string text;
char symbol;
int count = 0;
std::cout << "Введите текст: ";
std::getline(std::cin, text);
std::cout << "Введите символ: ";
std::cin >> symbol;
for (int i = 0; i < text.length(); i++) {
if (text[i] == symbol) {
count++;
}
}
std::cout << "Символ \"" << symbol << "\" встречается " << count << " раз(а) в тексте.\n";
return 0;
}
Эта программа запрашивает у пользователя текст и символ, затем считает, сколько раз символ встречается в тексте и выводит результат на экран.
Новые вопросы
Математика,
1 год назад
Українська мова,
1 год назад
Українська мова,
1 год назад
Русский язык,
6 лет назад