Информатика, вопрос задал afu18151 , 8 лет назад

Написать программу, которая запрашивает коэффициенты квадратного уравнения и сообщает, сколько корней имеет уравнение. Pascal ABC

Ответы на вопрос

Ответил DonPedro80
0
var
  a,b,c,d:real;
begin
  Write('Введите коэффициенты уравнения a,b,c: ');
  Readln(a,b,c);
  d:=b*b-4*a*c;
  if d<0 then Writeln('Корней нет')
  else if d=0 then Writeln('Один корень')
  else Writeln('Два корня')
end.
Новые вопросы