Информатика, вопрос задал lenalena1921 , 8 лет назад

Написать программу, которая запрашивает имя файла и распечатывает из него только те строки, которые являются палиндромами(python)

Ответы на вопрос

Ответил Аноним
0
# Python 3.6.1

print("Введите имя файла: ",end='')
f = open(input())
for S in f:
   if S[-1] == 'n':
      S = S[:-1]
   L = len(S)
   B = 1
   for i in range(L//2):
      if S[i] != S[L-i-1]: B = 0
   if B == 1:
      print(S)
Ответил lenalena1921
0
Версия 3.5.2
Ответил lenalena1921
0
файл есть. Ввожу print('введите имя файла',end='')
Ответил lenalena1921
0
f=open( input(),'r')
Ответил Аноним
0
Вы в интерактивном режиме построчно вводите? У меня так тоже ошибку выдаёт... сохраните в файл с .py. File → Open, найдите свой файл, откройте его и нажмите F5
Ответил Аноним
0
Ух, какой этот Питон капризный! ))
Новые вопросы