Написать программу, которая заполняет два одномерных массива случайными числами. Получить третий массив, элементы которого равны произведению соответствующих элементов исходных массивов. Pascal ABC
Ответы на вопрос
Ответил DonPedro80
0
const
n=15; { длина массива }
type
tm=array[1..n] of integer;
var
i:byte;
a,b,c:tm;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(101-50);
b[i]:=random(101-50);
c[i]:=a[i]*b[i];
Write(a[i],' ')
end;
Writeln;
for i:=1 to n do
begin
Write(b[i],' ')
end;
Writeln;
for i:=1 to n do
begin
Write(c[i],' ')
end;
Writeln
end.
n=15; { длина массива }
type
tm=array[1..n] of integer;
var
i:byte;
a,b,c:tm;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(101-50);
b[i]:=random(101-50);
c[i]:=a[i]*b[i];
Write(a[i],' ')
end;
Writeln;
for i:=1 to n do
begin
Write(b[i],' ')
end;
Writeln;
for i:=1 to n do
begin
Write(c[i],' ')
end;
Writeln
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Информатика,
8 лет назад
Биология,
8 лет назад