Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран
Ответы на вопрос
Ответил Студэнt
0
//прога на Pascal`e
const
n = 10;
var
a: array[0..n-1] of shortint;
i: byte;
begin
randomize;
writeln ('Исходный массив: ');
for i:=0 to n-1 do
begin
a[i]:=random (101)-50;
write (a[i], '; ');
end;
writeln ();
writeln ('Измененный массив: ');
for i:=0 to n-1 do
begin
a[i]:=abs (a[i]);
write (a[i], '; ');
end;
end.
const
n = 10;
var
a: array[0..n-1] of shortint;
i: byte;
begin
randomize;
writeln ('Исходный массив: ');
for i:=0 to n-1 do
begin
a[i]:=random (101)-50;
write (a[i], '; ');
end;
writeln ();
writeln ('Измененный массив: ');
for i:=0 to n-1 do
begin
a[i]:=abs (a[i]);
write (a[i], '; ');
end;
end.
Новые вопросы
Физика,
2 года назад
Математика,
2 года назад
Химия,
8 лет назад
История,
8 лет назад
Биология,
9 лет назад
Математика,
9 лет назад