написать программу которая задает с клавиатуры рост 10 спортсменов из диапазона от 150 до 200см считает количество спортсменов рост которых больше 190см а также средний рост всех спортсменов
Ответы на вопрос
Ответил den162Sil
0
var
a: array [1..10] of integer;
i, s, k: integer;
begin
for i:=1 to 10 do
begin
Writeln('Рост спортсмена №',i,': ');
Readln(a[i]);
if a[i] > 190 then
k:=k+1;
s:=s+a[i];
end;
Writeln(k, ' спортсмена(-ов) рост, которых составляет более 190 см.');
Writeln('Средний рост всех спортсменов составляет ', s/10,' см.');
end.
a: array [1..10] of integer;
i, s, k: integer;
begin
for i:=1 to 10 do
begin
Writeln('Рост спортсмена №',i,': ');
Readln(a[i]);
if a[i] > 190 then
k:=k+1;
s:=s+a[i];
end;
Writeln(k, ' спортсмена(-ов) рост, которых составляет более 190 см.');
Writeln('Средний рост всех спортсменов составляет ', s/10,' см.');
end.
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Химия,
8 лет назад
Литература,
8 лет назад
Математика,
9 лет назад
Алгебра,
9 лет назад