Написать программу, которая задаёт произвольное число из промежутка ( -15; 68 )
Ответы на вопрос
Ответ:
program z1;
begin
writeln(random(82)-14)
end.
Объяснение:
Конечный промежуток состоит из множества чисел, заключенных между двумя числами a и b - концами промежутка, которые сами могут быть включены в его состав, или нет.
Если a < числа из промежутка < b называется открытым промежутком (интервалом) и обозначается (a; b) - a и b в состав промежутка не входят.
Функция random генерирует случайное число в диапазоне от 0 до значения указанного в скобках (не включая само значение).
Например: random(82) - генерирует случайное число в диапазоне от 0 до 81.
Если требуется получать значения в каком-либо другом диапазоне (не от 0), то прибегают сначала записывают выражение random (21) в результате, сначала будет получено число из диапазона [0; 20], а затем из него вычитают 10. И если случайное число было меньше 10, то результат выражения будет отрицательным. В результате random (21) - 10 - получает числа из промежутка [-10; 10].
Например: random(82) - 14 - генерирует случайное число в диапазоне от 0 до 81, а затем вычитает из него 14, и если случайное число было меньше 14, то результат выражения будет отрицательным. В результате random(82) - 14 - получает числа из промежутка (-15; 68). -15 и 68 в состав промежутка не входят.