написать программу которая выводит в одномерном массиве заданным вводом данных с клавиатуры вычисляет сколько среди них чисел больших среднего арифметичского числа паскаль
Ответы на вопрос
Ответил gfhjkmgfhjkm20
0
Ответ:
const n=13;
var a:array [1..n] of integer;
i,s,k:integer;
begin
write('Введите ',n,' элементов массива через пробел: ');
for i:=1 to n do read(a[i]);
write ('Массив: ');
for i:=1 to n do write(a[i],' ');
writeln;
for i:=1 to n do s:=s+a[i];
writeln('Среднее арифметическое всех элементов массива равно: ',s/n:0:3);
for i:=1 to n do if a[i]>s/n then k:=k+1;
write('Элементов массива больших среднего арифметичского всех элементов массива: ',k);
end.
Объяснение:
Новые вопросы
Алгебра,
1 год назад
Математика,
2 года назад
Геометрия,
2 года назад
Алгебра,
7 лет назад
Математика,
7 лет назад