написать программу которая выводит пример на умножение однозначных чисел если не правильно то пишет не правильно и верный ответ ,а если правильно то правильно
Ответы на вопрос
Ответил Аноним
0
var
k,m,n:integer;
begin
Writeln('Проверка знания таблицы умножения');
Writeln('Вводите ответ или 0 для окончания работы');
Randomize;
repeat
k:=Random(9)+1;
m:=Random(9)+1;
Write(k,' x ',m,' = '); Read(n);
if n<>0 then
if n=k*m then Writeln('Верно!')
else Writeln('Неверно, ответ ',k*m)
until n=0;
Writeln('Всего доброго, приходите еще!')
end.
k,m,n:integer;
begin
Writeln('Проверка знания таблицы умножения');
Writeln('Вводите ответ или 0 для окончания работы');
Randomize;
repeat
k:=Random(9)+1;
m:=Random(9)+1;
Write(k,' x ',m,' = '); Read(n);
if n<>0 then
if n=k*m then Writeln('Верно!')
else Writeln('Неверно, ответ ',k*m)
until n=0;
Writeln('Всего доброго, приходите еще!')
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Математика,
8 лет назад
Литература,
9 лет назад