Информатика, вопрос задал pewpewsea , 9 лет назад

Написать программу, которая выводит ответ "Верно", если число в диапазоне от 100 до 150, кроме 120, и "Неверно" в других случаях

Ответы на вопрос

Ответил Vitalija10
0
program chisloq;
uses crt;
var q: real;
begin
writeln ('Введите число');
readln (q);
if (q <150) and (q>100) and
((q>120) or (q <120)) then
writeln ('ВЕРНО')
else writeln('НЕВЕРНО');
end.

Ответил Aillianna
0
а почему не просто q <> 120 ?
Ответил Aillianna
0
Правда? Школа это конечно "выдающееся" заведение. Но вообще в программировании культивируется оптимальность и читабельность кода. "Неравно" в паскале обозначается "<>", в языках типа С "!=", еще видела в Lua "~="
Новые вопросы