Информатика, вопрос задал Аноним00700 , 2 года назад

Написать программу , которая выводит целые числа в промежутке от до 50 , кратные восьми и считает их количество , сумму и произведение .
Пожалуйста помоги мне быстрее

Ответы на вопрос

Ответил petyaGavrikov
0
var i,k,s:integer; p:longint;
begin
k:=0; s:=0; p:=1;
for i:=1 to 50 do
 if i mod 8 = 0 then
  begin
  write(i,' ');
  k:=k+1;
  s:=s+i;
  p:=p*i;
  end;
 writeln;
 writeln('k = ',k,' s = ',s,' p = ',p);
 end.

Результат:
8 16 24 32 40 48
k = 6 s = 168 p = 188743680
Новые вопросы