Информатика, вопрос задал Killstation65 , 8 лет назад

Написать программу, которая выведет из N чисел числа кратные 3 и максимальное из них, если нет чисел кратных 3, вывести NO

Ответы на вопрос

Ответил AnonimusPro
0
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write('Введите n: ');
var a:=ArrRandom(ReadInteger(),1,100);
write('сгенерированный массив: ');
a.Println();
var b:=a.Where(x->x mod 3=0);
if(b.Count()<>0) then
begin
write('числа кратные 3: ' );
b.Println();
write('максимальное из кратных 3: ',b.Max());
end else write('no');
end.
Новые вопросы