Написать программу , которая вычисляет среднюю температуру воздуха за всю неделю. Выясните, сколько раз в неделю температура была выше нуля.
egor222777:
А что касается Вводных данных? За каждый день будет вводиться температура или как?
Ответы на вопрос
Ответил egor222777
1
Program Temperatura;
Var d, k, T: integer; f: byte; a: array [1..7] of integer;
Begin f := 0;k := 0;
Writeln('Введите температуру');
for d := 1 to 7 do Begin
Write(d, ' день: ');
Readln(a[d]);
end;
for d := 1 to 7 do if a[d] > 0 then
Begin
k := k + 1;
f := 1;
end;
if f = 0 then Writeln('Всю неделю температура была ниже нуля.')
else
Writeln('Дни с температурой выше нуля - ', k);
T := a[1] + a[2] + a[3] + a[4] + a[5] + a[6] + a[7];
WriteLn('Средняя температура за неделю:', T / 7:0:2);
end.
Var d, k, T: integer; f: byte; a: array [1..7] of integer;
Begin f := 0;k := 0;
Writeln('Введите температуру');
for d := 1 to 7 do Begin
Write(d, ' день: ');
Readln(a[d]);
end;
for d := 1 to 7 do if a[d] > 0 then
Begin
k := k + 1;
f := 1;
end;
if f = 0 then Writeln('Всю неделю температура была ниже нуля.')
else
Writeln('Дни с температурой выше нуля - ', k);
T := a[1] + a[2] + a[3] + a[4] + a[5] + a[6] + a[7];
WriteLn('Средняя температура за неделю:', T / 7:0:2);
end.
Новые вопросы
Информатика,
1 год назад
Қазақ тiлi,
1 год назад
Математика,
2 года назад
Химия,
7 лет назад
Биология,
7 лет назад