Написать программу, которая
- вводит в компьютер с клавиатуры годовые оценки К учеников класса;
- подсчитывает и выводит на экран среднюю оценку в классе;
- подсчитывает и выводит на экран количество учеников, у которых оценка выше средней.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var k:=ReadInteger('k=');
var a:=ReadArrInteger('Вводите оценки:',k);
var m:=a.Average;
Writeln('Средняя оценка по классу: ',m:4:2);
Writeln('Учеников с оценкой выше средней: ',a.Where(x->x>m).Count)
end.
// Внимание! Если программа не работает, обновите версию!
begin
var k:=ReadInteger('k=');
var a:=ReadArrInteger('Вводите оценки:',k);
var m:=a.Average;
Writeln('Средняя оценка по классу: ',m:4:2);
Writeln('Учеников с оценкой выше средней: ',a.Where(x->x>m).Count)
end.
Новые вопросы