Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не оказаться)
нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.
Ответы на вопрос
Ответил ad1997ya
0
#include <iostream>
#include <ctime>
using namespace std;
int main ()
{ srand (time(NULL));
short N;
cout << "N=";
cin >> N;
int *array=new int [N];
cout << "Random array: ";
for (short i=0;i<N;i++)
{
array[i]=rand()%21-10;
cout << array[i] << ' ';
}
cout << endl;
for (short i=0;i<N;i++)
{
if (array[i]==0)
cout << "Nulls: " << array[i] << "(index=" << i << ')' << ' ';
}
system ("PAUSE>>VOID");
return 0;
}
#include <ctime>
using namespace std;
int main ()
{ srand (time(NULL));
short N;
cout << "N=";
cin >> N;
int *array=new int [N];
cout << "Random array: ";
for (short i=0;i<N;i++)
{
array[i]=rand()%21-10;
cout << array[i] << ' ';
}
cout << endl;
for (short i=0;i<N;i++)
{
if (array[i]==0)
cout << "Nulls: " << array[i] << "(index=" << i << ')' << ' ';
}
system ("PAUSE>>VOID");
return 0;
}
Новые вопросы