Информатика, вопрос задал Arau , 10 лет назад

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран.

Ответы на вопрос

Ответил archery
0

var  a: array [1..100] of integer;
i,n,min,max:integer;
Begin
    read(n);
    for i := 1 to n do
        read(a[i]);

    min:=a[1];
    max:=a[1];
    for i:= 1 to n do begin
        write(a[i],' ');
        if max<a[i] then max:=a[i];
        if min>a[i] then min:=a[i];
    end;
    writeln(min,max);
End.

Новые вопросы